MariaDB 5.2 < 5.2.13 Buffer Overflow

Medium Nessus Plugin ID 63148


The remote database server is affected by a buffer overflow vulnerability.


The version of MariaDB 5.2 running on the remote host is prior to 5.2.13. It is, therefore, affected by a buffer overflow vulnerability.
A remote, authenticated attacker could exploit this to execute arbitrary code.


Upgrade to MariaDB version 5.2.13 or later.

See Also

Plugin Details

Severity: Medium

ID: 63148

File Name: mariadb_5_2_13.nasl

Version: 1.14

Type: remote

Family: Databases

Published: 2012/12/04

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/11/29

Vulnerability Publication Date: 2012/11/29

Reference Information

CVE: CVE-2012-5611

BID: 56769

EDB-ID: 23075