FreeBSD : opera -- multiple vulnerabilities (38daea4f-2851-11e2-9483-14dae938ec40)

High Nessus Plugin ID 62832


The remote FreeBSD host is missing one or more security-related updates.


Opera reports :

CORS (Cross-Origin Resource Sharing) allows web pages to retrieve the contents of pages from other sites, with their permission, as they would appear for the current user. When requests are made in this way, the browser should only allow the page content to be retrieved if the target site sends the correct headers that give permission for their contents to be used in this way. Specially crafted requests may trick Opera into thinking that the target site has given permission when it had not done so. This can result in the contents of any target page being revealed to untrusted sites, including any sensitive information or session IDs contained within the source of those pages.

Also reported are vulnerabilities involving SVG graphics and XSS.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 62832

File Name: freebsd_pkg_38daea4f285111e2948314dae938ec40.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2012/11/07

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-opera, p-cpe:/a:freebsd:freebsd:linux-opera-devel, p-cpe:/a:freebsd:freebsd:opera, p-cpe:/a:freebsd:freebsd:opera-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/11/06

Vulnerability Publication Date: 2012/11/06