MySQL 5.5 < 5.5.26 Multiple Vulnerabilities

medium Nessus Plugin ID 62640
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.26 and is, therefore, affected by vulnerabilities in the following components :

- InnoDB
- InnoDB Plugin
- Server
- Server Full Text Search

Solution

Upgrade to MySQL version 5.5.26 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-26.html

http://www.nessus.org/u?87547c81

Plugin Details

Severity: Medium

ID: 62640

File Name: mysql_5_5_26.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 10/19/2012

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/16/2012

Vulnerability Publication Date: 10/16/2012

Reference Information

CVE: CVE-2012-3156, CVE-2012-3166, CVE-2012-3167, CVE-2012-3173

BID: 56013, 56018, 56028, 56041