MySQL 5.1 < 5.1.64 Multiple Vulnerabilities

Medium Nessus Plugin ID 62637

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.64 and is, therefore, affected by vulnerabilities in the following components :

- InnoDB
- InnoDB Plugin
- Server Full Text Search

Solution

Upgrade to MySQL version 5.1.64 or later.

See Also

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-64.html

http://www.nessus.org/u?87547c81

Plugin Details

Severity: Medium

ID: 62637

File Name: mysql_5_1_64.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 2012/10/19

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/10/16

Vulnerability Publication Date: 2012/10/16

Reference Information

CVE: CVE-2012-3166, CVE-2012-3167, CVE-2012-3173

BID: 56018, 56028, 56041