FreeBSD : gitolite -- path traversal vulnerability (f94befcd-1289-11e2-a25e-525400272390)

Medium Nessus Plugin ID 62553


The remote FreeBSD host is missing a security-related update.


Sitaram Chamarty reports :

I'm sorry to say there is a potential path traversal vulnerability in v3. Thanks to Stephane Chazelas for finding it and alerting me.

Can it affect you? This can only affect you if you are using wild card repos, *and* at least one of your patterns allows the string '../' to match multiple times.

How badly can it affect you? A malicious user who *also* has the ability to create arbitrary files in, say, /tmp (e.g., he has his own userid on the same box), can compromise the entire 'git' user.
Otherwise the worst he can do is create arbitrary repos in /tmp.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 62553

File Name: freebsd_pkg_f94befcd128911e2a25e525400272390.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2012/10/16

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:N/AC:H/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gitolite, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/10/15

Vulnerability Publication Date: 2012/10/09

Reference Information

CVE: CVE-2012-4506