FreeBSD : dns/bind9* -- Several vulnerabilities (53a0ddef-0208-11e2-8afa-0024e830109b)

High Nessus Plugin ID 62194


The remote FreeBSD host is missing one or more security-related updates.


ISC reports :

Prevents a crash when queried for a record whose RDATA exceeds 65535 bytes.

Prevents a crash when validating caused by using 'Bad cache' data before it has been initialized.

ISC_QUEUE handling for recursive clients was updated to address a race condition that could cause a memory leak. This rarely occurred with UDP clients, but could be a significant problem for a server handling a steady rate of TCP queries.

A condition has been corrected where improper handling of zero-length RDATA could cause undesirable behavior, including termination of the named process.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 62194

File Name: freebsd_pkg_53a0ddef020811e28afa0024e830109b.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/09/19

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:bind96, p-cpe:/a:freebsd:freebsd:bind97, p-cpe:/a:freebsd:freebsd:bind98, p-cpe:/a:freebsd:freebsd:bind99, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/09/18

Vulnerability Publication Date: 2012/09/12