FreeBSD : rubygem-rails -- multiple vulnerabilities (31db9a18-e289-11e1-a57d-080027a27dbf)

Medium Nessus Plugin ID 61480


The remote FreeBSD host is missing one or more security-related updates.


Rails core team reports :

This version contains three important security fixes, please upgrade immediately.

One of security fixes impacts all users and is related to HTML escaping code. The other two fixes impacts people using select_tag's prompt option and strip_tags helper from ActionPack.

CVE-2012-3463 Potential XSS Vulnerability in select_tag prompt.

CVE-2012-3464 Potential XSS Vulnerability in the HTML escaping code.

CVE-2012-3465 XSS Vulnerability in strip_tags.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 61480

File Name: freebsd_pkg_31db9a18e28911e1a57d080027a27dbf.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/08/10

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem-actionpack, p-cpe:/a:freebsd:freebsd:rubygem-activesupport, p-cpe:/a:freebsd:freebsd:rubygem-rails, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/08/10

Vulnerability Publication Date: 2012/08/08

Reference Information

CVE: CVE-2012-3463, CVE-2012-3464, CVE-2012-3465