FreeBSD : FreeBSD -- named(8) DNSSEC validation Denial of Service (0f020b7b-e033-11e1-90a2-000c299b62e1)

High Nessus Plugin ID 61443


The remote FreeBSD host is missing one or more security-related updates.


Problem description :

BIND 9 stores a cache of query names that are known to be failing due to misconfigured name servers or a broken chain of trust. Under high query loads, when DNSSEC validation is active, it is possible for a condition to arise in which data from this cache of failing queries could be used before it was fully initialized, triggering an assertion failure.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 61443

File Name: freebsd_pkg_0f020b7be03311e190a2000c299b62e1.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2012/08/07

Modified: 2016/11/23

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:FreeBSD, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/08/07

Vulnerability Publication Date: 2012/07/24

Reference Information

CVE: CVE-2012-3817

BID: 54658

OSVDB: 84228

FreeBSD: SA-12:05.bind