Scientific Linux Security Update : libwpd on SL5.x i386/x86_64

High Nessus Plugin ID 61355


The remote Scientific Linux host is missing one or more security updates.


libwpd is a library for reading and converting Corel WordPerfect Office documents.

A buffer overflow flaw was found in the way libwpd processed certain Corel WordPerfect Office documents (.wpd files). An attacker could provide a specially crafted .wpd file that, when opened in an application linked against libwpd, such as, would cause the application to crash or, potentially, execute arbitrary code with the privileges of the user running the application. (CVE-2012-2149)

All libwpd users are advised to upgrade to these updated packages, which contain a backported patch to correct this issue. All running applications that are linked against libwpd must be restarted for this update to take effect.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 61355

File Name: sl_20120626_libwpd_on_SL5_x.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2012/08/01

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2012/06/26

Reference Information

CVE: CVE-2012-2149