FreeBSD : p5-RT-Authen-ExternalAuth -- privilege escalation (cdc4ff0e-d736-11e1-8221-e0cb4e266481)

Medium Nessus Plugin ID 60135


The remote FreeBSD host is missing a security-related update.


The RT development team reports :

RT::Authen::ExternalAuth 0.10 and below (for all versions of RT) are vulnerable to an escalation of privilege attack where the URL of a RSS feed of the user can be used to acquire a fully logged-in session as that user. CVE-2012-2770 has been assigned to this vulnerability.

Users of RT 3.8.2 and above should upgrade to RT::Authen::ExternalAuth 0.11, which resolves this vulnerability.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 60135

File Name: freebsd_pkg_cdc4ff0ed73611e18221e0cb4e266481.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2012/07/27

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:p5-RT-Authen-ExternalAuth, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/07/26

Vulnerability Publication Date: 2012/07/25

Reference Information

CVE: CVE-2012-2770