Nagios XI < 2011R3.0 Multiple XSS Vulnerabilities

Medium Nessus Plugin ID 60099

Synopsis

The remote web server contains a PHP application that is affected by
multiple cross-site scripting vulnerabilities.

Description

The version of Nagios XI hosted on the remote web server fails to
properly sanitize input to multiple web pages.

- A cross-site scripting vulnerability exists in the
'view' parameter of the 'perfgraphs/index.php' script.

- A cross-site scripting vulnerability exists in the 'div'
parameter of the 'graphexplorer/visApi.php' script.

- Multiple unspecified cross-site scripting
vulnerabilities.

An attacker can leverage these issues by enticing a user to follow a
malicious URL, causing attacker-specified script code to run inside
the user's browser in the context of the affected site. Information
harvested this way may aid in launching further attacks.

Solution

Upgrade to Nagios XI 2011R3.0 or later.

See Also

http://0a29.blogspot.com/2012/06/0a29-12-1-cross-site-scripting.html

https://seclists.org/bugtraq/2012/Jul/11

https://assets.nagios.com/downloads/nagiosxi/CHANGES-2011.TXT

Plugin Details

Severity: Medium

ID: 60099

File Name: nagiosxi_2011r3_0.nasl

Version: 1.11

Type: remote

Published: 2012/07/23

Modified: 2018/11/15

Dependencies: 49774

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nagios:nagios

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/12/14

Vulnerability Publication Date: 2011/12/13

Reference Information

BID: 54262

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990