SuSE 10 Security Update : pidgin, finch and libpurple (ZYPP Patch Number 8220)

High Nessus Plugin ID 60059


The remote SuSE 10 host is missing a security-related patch.


This update of pidgin fixes a stack-based buffer overflow in the MXit protocol which could have potentially been exploited by remote attackers to execute arbitrary code in the context of the user running pidgin. (CVE-2012-3374)


Apply ZYPP patch number 8220.

See Also

Plugin Details

Severity: High

ID: 60059

File Name: suse_finch-8220.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2012/07/19

Modified: 2012/07/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2012/07/16

Reference Information

CVE: CVE-2012-3374