FreeBSD : libjpeg-turbo -- heap-based buffer overflow (a460035e-d111-11e1-aff7-001fd056c417)

Medium Nessus Plugin ID 60056


The remote FreeBSD host is missing a security-related update.


The Changelog for version 1.2.1 says: Fixed a regression caused by 1.2.0[6] in which decompressing corrupt JPEG images (specifically, images in which the component count was erroneously set to a large value) would cause libjpeg-turbo to segfault.

A Heap-based buffer overflow was found in the way libjpeg-turbo decompressed certain corrupt JPEG images in which the component count was erroneously set to a large value. An attacker could create a specially crafted JPEG image that, when opened, could cause an application using libpng to crash or, possibly, execute arbitrary code with the privileges of the user running the application.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 60056

File Name: freebsd_pkg_a460035ed11111e1aff7001fd056c417.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/07/19

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libjpeg-turbo, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/07/18

Vulnerability Publication Date: 2012/05/31

Reference Information

CVE: CVE-2012-2806