MySQL 5.5 < 5.5.23 Multiple Unspecified Vulnerabilities

critical Nessus Plugin ID 59967
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple unspecified vulnerabilities.

Description

The version of MySQL 5.5 installed on the remote host is a version prior to 5.5.23. As such, it is affected by two unspecified vulnerabilities related to the 'Server Optimizer' component.

Solution

Upgrade to MySQL version 5.5.23 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-23.html

https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=833742

http://www.nessus.org/u?6d4671b2

http://www.nessus.org/u?f2d5fae1

Plugin Details

Severity: Critical

ID: 59967

File Name: mysql_5_5_23.nasl

Version: 1.11

Type: remote

Family: Databases

Published: 7/13/2012

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/12/2012

Vulnerability Publication Date: 4/12/2012

Reference Information

CVE: CVE-2012-1689, CVE-2012-2750

BID: 54547, 63125