Debian DSA-2487-1 : openoffice.org - buffer overflow

High Nessus Plugin ID 59765

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that OpenOffice.org would not properly process crafted document files, possibly leading to arbitrary code execution.

- CVE-2012-1149 Integer overflows in PNG image handling.

- CVE-2012-2334 Integer overflow in operator new[] invocation and heap-based buffer overflow inside the MS-ODRAW parser.

Solution

Upgrade the openoffice.org packages.

For the stable distribution (squeeze), this problem has been fixed in version 1:3.2.1-11+squeeze6.

See Also

https://security-tracker.debian.org/tracker/CVE-2012-1149

https://security-tracker.debian.org/tracker/CVE-2012-2334

https://packages.debian.org/source/squeeze/openoffice.org

https://www.debian.org/security/2012/dsa-2487

Plugin Details

Severity: High

ID: 59765

File Name: debian_DSA-2487.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2012/06/29

Updated: 2020/03/12

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openoffice.org, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/06/07

Reference Information

CVE: CVE-2012-1149, CVE-2012-2334

BID: 53570

DSA: 2487