CVE-2012-2334

MEDIUM

Description

Integer overflow in filter/source/msfilter/msdffimp.cxx in OpenOffice.org (OOo) 3.3, 3.4 Beta, and possibly earlier, and LibreOffice before 3.5.3, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via the length of an Escher graphics record in a PowerPoint (.ppt) document, which triggers a buffer overflow.

References

http://archives.neohapsis.com/archives/bugtraq/2012-05/0091.html

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28a6558f9d3ca2dda3191f8b5b3f2378ee2533da

http://cgit.freedesktop.org/libreoffice/core/commit/?id=512401decb286ba0fc3031939b8f7de8649c502e

http://lists.fedoraproject.org/pipermail/package-announce/2012-June/082168.html

http://rhn.redhat.com/errata/RHSA-2012-0705.html

http://secunia.com/advisories/46992

http://secunia.com/advisories/47244

http://secunia.com/advisories/49373

http://secunia.com/advisories/49392

http://secunia.com/advisories/60799

http://securitytracker.com/id?1027070

http://www.debian.org/security/2012/dsa-2487

http://www.gentoo.org/security/en/glsa/glsa-201408-19.xml

http://www.libreoffice.org/advisories/cve-2012-2334/

http://www.mandriva.com/security/advisories?name=MDVSA-2012:090

http://www.mandriva.com/security/advisories?name=MDVSA-2012:091

http://www.openoffice.org/security/cves/CVE-2012-2334.html

http://www.openwall.com/lists/oss-security/2012/05/28/2

http://www.osvdb.org/82517

http://www.securityfocus.com/bid/53570

https://bugzilla.redhat.com/show_bug.cgi?id=821803

https://exchange.xforce.ibmcloud.com/vulnerabilities/75695

Details

Source: MITRE

Published: 2012-06-19

Updated: 2017-08-29

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM