PHP 5.4.x < 5.4.4 Multiple Vulnerabilities

High Nessus Plugin ID 59530

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is 5.4.x earlier than 5.4.4, and as such is potentially affected the following vulnerabilities :

- An integer overflow error exists in the function 'phar_parse_tarfile' in the file 'ext/phar/tar.c'. This error can lead to a heap-based buffer overflow when handling a maliciously crafted TAR files. Arbitrary code execution is possible due to this error. (CVE-2012-2386)

- A weakness exists in the 'crypt' function related to the DES implementation that can allow brute-force attacks. (CVE-2012-2143)

- Several design errors involving the incorrect parsing of PHP PDO prepared statements could lead to disclosure of sensitive information or denial of service.
(CVE-2012-3450)

Solution

Upgrade to PHP version 5.4.4 or later.

See Also

http://www.nessus.org/u?ec6f812f

https://bugs.php.net/bug.php?id=61755

http://www.php.net/ChangeLog-5.php#5.4.4

http://www.nessus.org/u?99140286

Plugin Details

Severity: High

ID: 59530

File Name: php_5_4_4.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 2012/06/15

Updated: 2018/11/15

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2012/06/14

Vulnerability Publication Date: 2011/04/21

Reference Information

CVE: CVE-2012-2143, CVE-2012-2386, CVE-2012-3450

BID: 47545, 53729, 54777

EDB-ID: 17201