CVE-2012-3450

low
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

pdo_sql_parser.re in the PDO extension in PHP before 5.3.14 and 5.4.x before 5.4.4 does not properly determine the end of the query string during parsing of prepared statements, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted parameter value.

References

http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00021.html

http://seclists.org/bugtraq/2012/Jun/60

http://www.debian.org/security/2012/dsa-2527

http://www.mandriva.com/security/advisories?name=MDVSA-2012:108

http://www.openwall.com/lists/oss-security/2012/08/02/3

http://www.openwall.com/lists/oss-security/2012/08/02/7

http://www.php.net/ChangeLog-5.php

http://www.ubuntu.com/usn/USN-1569-1

https://bugs.php.net/bug.php?id=61755

https://bugzilla.novell.com/show_bug.cgi?id=769785

Details

Source: MITRE

Published: 2012-08-06

Updated: 2013-04-19

Risk Information

CVSS v2

Base Score: 2.6

Vector: AV:N/AC:H/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 4.9

Severity: LOW

Tenable Plugins

View all (9 total)

IDNameProductFamilySeverity
9097PHP 5.3.x < 5.3.14 / 5.4.x < 5.4.4 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
64106SuSE 11.2 Security Update : PHP5 (SAT Patch Number 6634)NessusSuSE Local Security Checks
critical
64105SuSE 11.2 Security Update : PHP5 (SAT Patch Number 6634)NessusSuSE Local Security Checks
critical
62236GLSA-201209-03 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
62178Ubuntu 8.04 LTS / 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : php5 vulnerabilities (USN-1569-1)NessusUbuntu Local Security Checks
critical
61961Mandriva Linux Security Advisory : php (MDVSA-2012:108)NessusMandriva Local Security Checks
critical
61520Debian DSA-2527-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
critical
59530PHP 5.4.x < 5.4.4 Multiple VulnerabilitiesNessusCGI abuses
high
59529PHP 5.3.x < 5.3.14 Multiple VulnerabilitiesNessusCGI abuses
high