PHP 5.3.x < 5.3.14 Multiple Vulnerabilities

High Nessus Plugin ID 59529


The remote web server uses a version of PHP that is affected by
multiple vulnerabilities.


According to its banner, the version of PHP installed on the remote
host is 5.3.x earlier than 5.3.14, and is, therefore, potentially
affected the following vulnerabilities :

- An integer overflow error exists in the function
'phar_parse_tarfile' in the file 'ext/phar/tar.c'. This
error can lead to a heap-based buffer overflow when
handling a maliciously crafted TAR file. Arbitrary code
execution is possible due to this error. (CVE-2012-2386)

- A weakness exists in the 'crypt' function related to
the DES implementation that can allow brute-force
attacks. (CVE-2012-2143)

- Several design errors involving the incorrect parsing
of PHP PDO prepared statements could lead to disclosure
of sensitive information or denial of service.

- A variable initialization error exists in the file
'ext/openssl/openssl.c' that can allow process memory
contents to be disclosed when input data is of length
zero. (CVE-2012-6113)


Upgrade to PHP version 5.3.14 or later.

See Also

Plugin Details

Severity: High

ID: 59529

File Name: php_5_3_14.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 2012/06/15

Modified: 2018/11/15

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2012-2386

CVSS Score Rationale: The in depth report by packetstorm supports complete compromise.

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2012/06/14

Vulnerability Publication Date: 2011/04/21

Reference Information

CVE: CVE-2012-2143, CVE-2012-2386, CVE-2012-3450, CVE-2012-6113

BID: 47545, 53729, 54777, 57462

EDB-ID: 17201