SuSE 10 Security Update : libpng (ZYPP Patch Number 8043)

Medium Nessus Plugin ID 59494


The remote SuSE 10 host is missing a security-related patch.


The following security issue has been fixed :

- specially crafted png files could have caused a memory corruption in libpng's png_set_text_2() function.


Apply ZYPP patch number 8043.

See Also

Plugin Details

Severity: Medium

ID: 59494

File Name: suse_libpng-8043.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2012/06/14

Modified: 2012/06/15

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2012/03/30

Reference Information

CVE: CVE-2011-3048