Pretty Link Plugin for WordPress 'pretty-bar.php' 'url' Parameter XSS

Medium Nessus Plugin ID 59387

Synopsis

The remote web server hosts a PHP script that is affected by a cross-
site scripting vulnerability.

Description

The version of the Pretty Link Lite plugin for WordPress installed on
the remote host fails to properly sanitize user-supplied input to the
'url' parameter of the 'pretty-bar.php' script before using it to
generate dynamic HTML output. An attacker can leverage this issue to
inject arbitrary HTML and script code into a user's browser to be
executed within the security context of the affected site.

Note that the install is also reportedly affected by an additional
cross-site scripting issue as well as a SQL injection vulnerability;
however, Nessus has not tested for these.

Solution

Upgrade to Pretty Link Lite 1.5.4 or later

See Also

https://packetstormsecurity.com/files/107551/wordpressprettylink-xss.txt

http://www.nessus.org/u?64d545c5

https://wordpress.org/plugins/pretty-link/#changelog

Plugin Details

Severity: Medium

ID: 59387

File Name: wordpress_pretty_link_lite_url_xss.nasl

Version: 1.7

Type: remote

Published: 2012/06/06

Modified: 2018/11/15

Dependencies: 18297

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2011/12/03

Vulnerability Publication Date: 2011/12/06

Reference Information

CVE: CVE-2011-4595

BID: 53531

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990