FreeBSD : quagga -- BGP OPEN denial of service vulnerability (1e14d46f-af1f-11e1-b242-00215af774f0)

Low Nessus Plugin ID 59380


The remote FreeBSD host is missing one or more security-related updates.


CERT reports :

If a pre-configured BGP peer sends a specially crafted OPEN message with a malformed ORF capability TLV, Quagga bgpd process will erroneously try to consume extra bytes from the input packet buffer.
The process will detect a buffer overrun attempt before it happens and immediately terminate with an error message. All BGP sessions established by the attacked router will be closed and its BGP routing disrupted.


Update the affected packages.

See Also

Plugin Details

Severity: Low

ID: 59380

File Name: freebsd_pkg_1e14d46faf1f11e1b24200215af774f0.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2012/06/06

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.9

Vector: CVSS2#AV:A/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:quagga, p-cpe:/a:freebsd:freebsd:quagga-re, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/06/05

Vulnerability Publication Date: 2012/06/04

Reference Information

CVE: CVE-2012-1820

CERT: 962587