SuSE 10 Security Update : popt (ZYPP Patch Number 8093)

High Nessus Plugin ID 59164


The remote SuSE 10 host is missing a security-related patch.


Multiple security vulnerabilities were reported in RPM which could have been exploited via specially crafted RPM files to cause a denial of service (application crash) or potentially allow attackers to execute arbitrary code.

Additionally, a non-security issue was fixed that could cause a division by zero in cycles calculation under rare circumstances.


Apply ZYPP patch number 8093.

Plugin Details

Severity: High

ID: 59164

File Name: suse_popt-8093.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2012/05/17

Modified: 2012/05/17

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2012/04/23