SuSE 10 Security Update : the Linux kernel (x86_64) (ZYPP Patch Number 7063)

High Nessus Plugin ID 59149


The remote SuSE 10 host is missing a security-related patch.


This SUSE Linux Enterprise 10 SP3 kernel update fixes a severe regression introduced by previous bugfix updates that would corrupt NFSv4 mounted data.

The update also fixes several other bugs and following security issue :

- drivers/net/r8169.c in the r8169 driver of Linux kernel and earlier does not properly check the size of an Ethernet frame that exceeds the maximum transmission unit (MTU), which allows remote attackers to.

1. cause a denial of service (temporary network outage) via a packet with a crafted size, in conjunction with certain packets containing A characters and certain packets containing E characters; or 2. cause a denial of service (system crash) via a packet with a crafted size, in conjunction with certain packets containing '0' characters, related to the value of the status register and erroneous behavior associated with the RxMaxSize register.

- An information leak in 32bit emulation on x86_64 machines could disclose sensitive information to local attackers. (CVE-2008-0598)


Apply ZYPP patch number 7063.

See Also

Plugin Details

Severity: High

ID: 59149

File Name: suse_kernel-7063.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2012/05/17

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/05/30

Reference Information

CVE: CVE-2008-0598, CVE-2009-4537

CWE: 20, 200