FreeBSD : php -- vulnerability in certain CGI-based setups (60de13d5-95f0-11e1-806a-001143cd36d8)

High Nessus Plugin ID 59009


The remote FreeBSD host is missing one or more security-related updates.


php development team reports :

Security Enhancements and Fixes in PHP 5.3.12 :

- Initial fix for cgi-bin ?-s cmdarg parse issue (CVE-2012-1823)


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 59009

File Name: freebsd_pkg_60de13d595f011e1806a001143cd36d8.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2012/05/07

Modified: 2014/03/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:php4, p-cpe:/a:freebsd:freebsd:php5, p-cpe:/a:freebsd:freebsd:php52, p-cpe:/a:freebsd:freebsd:php53, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/05/05

Vulnerability Publication Date: 2012/05/03

Exploitable With


Core Impact

Metasploit (PHP CGI Argument Injection)

Reference Information

CVE: CVE-2012-1823