SuSE 10 Security Update : wireshark (ZYPP Patch Number 8085)

Medium Nessus Plugin ID 58945

Synopsis

The remote SuSE 10 host is missing a security-related patch.

Description

This version upgrade of wireshark fixes the following security vulnerabilities :

- The ANSI A dissector could dereference a NULL pointer and crash. (CVE-2012-1593)

- The pcap and pcap-ng file parsers could crash trying to read ERF data. (CVE-2012-1595)

- The MP2T dissector could try to allocate too much memory and crash. (CVE-2012-1596) Additionally, various other non-security bugs have been fixed.

Solution

Apply ZYPP patch number 8085.

See Also

http://support.novell.com/security/cve/CVE-2012-1593.html

http://support.novell.com/security/cve/CVE-2012-1595.html

http://support.novell.com/security/cve/CVE-2012-1596.html

Plugin Details

Severity: Medium

ID: 58945

File Name: suse_wireshark-8085.nasl

Version: Revision: 1.3

Type: local

Agent: unix

Published: 2012/05/01

Updated: 2012/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2012/04/21

Reference Information

CVE: CVE-2012-1593, CVE-2012-1595, CVE-2012-1596