SuSE 11.1 Security Update : Samba (SAT Patch Number 6210)

Medium Nessus Plugin ID 58941

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

This update of Samba includes the following fixes for two security issues :

- Ensure that users cannot hand out their own privileges to everyone, only administrators are allowed to do that.
(CVE-2012-2111)

- mount.cifs no longer allows unprivileged users to mount onto dirs that are not accessible to them.
(CVE-2012-1586)

Solution

Apply SAT patch number 6210.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=754443

https://bugzilla.novell.com/show_bug.cgi?id=757080

https://bugzilla.novell.com/show_bug.cgi?id=757576

http://support.novell.com/security/cve/CVE-2012-1568.html

http://support.novell.com/security/cve/CVE-2012-1586.html

http://support.novell.com/security/cve/CVE-2012-2111.html

Plugin Details

Severity: Medium

ID: 58941

File Name: suse_11_cifs-mount-120424.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2012/05/01

Updated: 2018/07/31

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:cifs-mount, p-cpe:/a:novell:suse_linux:11:ldapsmb, p-cpe:/a:novell:suse_linux:11:libsmbclient0, p-cpe:/a:novell:suse_linux:11:libsmbclient0-32bit, p-cpe:/a:novell:suse_linux:11:libtalloc1, p-cpe:/a:novell:suse_linux:11:libtalloc1-32bit, p-cpe:/a:novell:suse_linux:11:libtdb1, p-cpe:/a:novell:suse_linux:11:libtdb1-32bit, p-cpe:/a:novell:suse_linux:11:libwbclient0, p-cpe:/a:novell:suse_linux:11:libwbclient0-32bit, p-cpe:/a:novell:suse_linux:11:samba, p-cpe:/a:novell:suse_linux:11:samba-32bit, p-cpe:/a:novell:suse_linux:11:samba-client, p-cpe:/a:novell:suse_linux:11:samba-client-32bit, p-cpe:/a:novell:suse_linux:11:samba-doc, p-cpe:/a:novell:suse_linux:11:samba-krb-printing, p-cpe:/a:novell:suse_linux:11:samba-winbind, p-cpe:/a:novell:suse_linux:11:samba-winbind-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/04/24

Reference Information

CVE: CVE-2012-1568, CVE-2012-1586, CVE-2012-2111

BID: 53307