FreeBSD : samba -- incorrect permission checks vulnerability (0fa15e08-92ec-11e1-a94a-00215c6a37bb)

Medium Nessus Plugin ID 58937


The remote FreeBSD host is missing one or more security-related updates.


The Samba project reports :

Samba versions 3.4.x to 3.6.4 inclusive are affected by a vulnerability that allows arbitrary users to modify privileges on a file server.

Security checks were incorrectly applied to the Local Security Authority (LSA) remote proceedure calls (RPC) CreateAccount, OpenAccount, AddAccountRights and RemoveAccountRights allowing any authenticated user to modify the privileges database.

This is a serious error, as it means that authenticated users can connect to the LSA and grant themselves the 'take ownership' privilege. This privilege is used by the smbd file server to grant the ability to change ownership of a file or directory which means users could take ownership of files or directories they do not own.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 58937

File Name: freebsd_pkg_0fa15e0892ec11e1a94a00215c6a37bb.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2012/05/01

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:samba34, p-cpe:/a:freebsd:freebsd:samba35, p-cpe:/a:freebsd:freebsd:samba36, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/04/30

Vulnerability Publication Date: 2012/04/30

Reference Information

CVE: CVE-2012-2111

BID: 53307

OSVDB: 81648