FreeBSD : puppet -- Multiple Vulnerabilities (607d2108-a0e4-423a-bf78-846f2a8f01b0)

Medium Nessus Plugin ID 58670


The remote FreeBSD host is missing a security-related update.


Multiple vulnerabilities exist in puppet that can result in arbitrary code execution, arbitrary file read access, denial of service, and arbitrary file write access. Please review the details in each of the CVEs for additional information.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 58670

File Name: freebsd_pkg_607d2108a0e4423abf78846f2a8f01b0.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/04/11

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:puppet, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/04/10

Vulnerability Publication Date: 2012/03/26

Reference Information

CVE: CVE-2012-1906, CVE-2012-1986, CVE-2012-1987, CVE-2012-1988, CVE-2012-1989