SuSE 11.1 Security Update : Java 1.6.0 (SAT Patch Number 5845)

Critical Nessus Plugin ID 58141

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

java-1_6_0-openjdk was updated to the IcedTea 1.11.1 b24 release, fixing multiple security issues :

- S7082299, CVE-2011-3571: Fix inAtomicReferenceArray

- S7088367, CVE-2011-3563: Fix issues in java sound

- S7110683, CVE-2012-0502: Issues with some KeyboardFocusManager method

- S7110687, CVE-2012-0503: Issues with TimeZone class

- S7110700, CVE-2012-0505: Enhance exception throwing mechanism in ObjectStreamClass

- S7110704, CVE-2012-0506: Issues with some method in corba

- S7112642, CVE-2012-0497: Incorrect checking for graphics rendering object

- S7118283, CVE-2012-0501: Better input parameter checking in zip file processing

- S7126960, CVE-2011-5035: (httpserver) Add property to limit number of request headers to the HTTP Server

Solution

Apply SAT patch number 5845.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=747208

http://support.novell.com/security/cve/CVE-2011-3563.html

http://support.novell.com/security/cve/CVE-2011-3571.html

http://support.novell.com/security/cve/CVE-2011-5035.html

http://support.novell.com/security/cve/CVE-2012-0497.html

http://support.novell.com/security/cve/CVE-2012-0501.html

http://support.novell.com/security/cve/CVE-2012-0502.html

http://support.novell.com/security/cve/CVE-2012-0503.html

http://support.novell.com/security/cve/CVE-2012-0505.html

http://support.novell.com/security/cve/CVE-2012-0506.html

Plugin Details

Severity: Critical

ID: 58141

File Name: suse_11_java-1_6_0-openjdk-120220.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2012/02/28

Updated: 2019/10/16

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:java-1_6_0-openjdk, p-cpe:/a:novell:suse_linux:11:java-1_6_0-openjdk-demo, p-cpe:/a:novell:suse_linux:11:java-1_6_0-openjdk-devel, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/02/20

Reference Information

CVE: CVE-2011-3563, CVE-2011-3571, CVE-2011-5035, CVE-2012-0497, CVE-2012-0501, CVE-2012-0502, CVE-2012-0503, CVE-2012-0505, CVE-2012-0506