SuSE 11.1 Security Update : libxml2 (SAT Patch Number 5654)

High Nessus Plugin ID 57682


The remote SuSE 11 host is missing one or more security updates.


A heap-based buffer overflow during decoding of entity references with overly long names has been fixed. CVE-2011-3919 has been assigned.


Apply SAT patch number 5654.

See Also

Plugin Details

Severity: High

ID: 57682

File Name: suse_11_libxml2-120116.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2012/01/25

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libxml2, p-cpe:/a:novell:suse_linux:11:libxml2-32bit, p-cpe:/a:novell:suse_linux:11:libxml2-doc, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2012/01/16

Reference Information

CVE: CVE-2011-3919