Cacti < 0.8.7g Multiple XSS and HTML Injection Vulnerabilities

medium Nessus Plugin ID 57617

Synopsis

The remote web server is running a PHP application that is affected by multiple cross-site scripting and HTML injection vulnerabilities.

Description

According to its self-reported version number, the Cacti application running on the remote web server is prior to version 0.8.7g. It is, therefore, potentially affected by multiple cross-site scripting and HTML injection vulnerabilities. An attacker may be able to exploit these issues to inject arbitrary HTML or script code into a user's browser to be executed within the security context of the affected site.

Solution

Upgrade to Cacti 0.8.7g or later.

See Also

https://cacti.net/release_notes_0_8_7g.php

https://marc.info/?l=oss-security&m=127978954522586

Plugin Details

Severity: Medium

ID: 57617

File Name: cacti_087g.nasl

Version: 1.13

Type: remote

Published: 1/20/2012

Updated: 4/11/2022

Configuration: Enable paranoid mode, Enable thorough checks

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:cacti:cacti

Required KB Items: www/PHP, installed_sw/cacti, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 7/10/2010

Vulnerability Publication Date: 7/10/2010

Reference Information

CVE: CVE-2010-2544, CVE-2010-2545

BID: 42575

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990