RHEL 4 / 5 / 6 : java-1.6.0-ibm (RHSA-2012:0034) (BEAST)

Critical Nessus Plugin ID 57595

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

Updated java-1.6.0-ibm packages that fix several security issues are now available for Red Hat Enterprise Linux 4 Extras, and Red Hat Enterprise Linux 5 and 6 Supplementary.

The Red Hat Security Response Team has rated this update as having critical security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulnerability from the CVE links in the References section.

The IBM Java SE version 6 release includes the IBM Java 6 Runtime Environment and the IBM Java 6 Software Development Kit.

This update fixes several vulnerabilities in the IBM Java 6 Runtime Environment and the IBM Java 6 Software Development Kit. Detailed vulnerability descriptions are linked from the IBM 'Security alerts' page, listed in the References section. (CVE-2011-3389, CVE-2011-3516, CVE-2011-3521, CVE-2011-3544, CVE-2011-3545, CVE-2011-3546, CVE-2011-3547, CVE-2011-3548, CVE-2011-3549, CVE-2011-3550, CVE-2011-3551, CVE-2011-3552, CVE-2011-3553, CVE-2011-3554, CVE-2011-3556, CVE-2011-3557, CVE-2011-3560, CVE-2011-3561)

All users of java-1.6.0-ibm are advised to upgrade to these updated packages, containing the IBM Java 6 SR10 release. All running instances of IBM Java must be restarted for the update to take effect.

Solution

Update the affected packages.

See Also

https://access.redhat.com/security/cve/cve-2011-3389

https://access.redhat.com/security/cve/cve-2011-3516

https://access.redhat.com/security/cve/cve-2011-3521

https://access.redhat.com/security/cve/cve-2011-3544

https://access.redhat.com/security/cve/cve-2011-3545

https://access.redhat.com/security/cve/cve-2011-3546

https://access.redhat.com/security/cve/cve-2011-3547

https://access.redhat.com/security/cve/cve-2011-3548

https://access.redhat.com/security/cve/cve-2011-3549

https://access.redhat.com/security/cve/cve-2011-3550

https://access.redhat.com/security/cve/cve-2011-3551

https://access.redhat.com/security/cve/cve-2011-3552

https://access.redhat.com/security/cve/cve-2011-3553

https://access.redhat.com/security/cve/cve-2011-3554

https://access.redhat.com/security/cve/cve-2011-3556

https://access.redhat.com/security/cve/cve-2011-3557

https://access.redhat.com/security/cve/cve-2011-3560

https://access.redhat.com/security/cve/cve-2011-3561

https://developer.ibm.com/javasdk/support/security-vulnerabilities/

https://access.redhat.com/errata/RHSA-2012:0034

Plugin Details

Severity: Critical

ID: 57595

File Name: redhat-RHSA-2012-0034.nasl

Version: 1.26

Type: local

Agent: unix

Published: 2012/01/19

Updated: 2019/10/24

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm, p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm-accessibility, p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm-demo, p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm-devel, p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm-javacomm, p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm-jdbc, p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm-plugin, p-cpe:/a:redhat:enterprise_linux:java-1.6.0-ibm-src, cpe:/o:redhat:enterprise_linux:4, cpe:/o:redhat:enterprise_linux:5, cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:6.1

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/01/18

Vulnerability Publication Date: 2011/09/06

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Java RMI Server Insecure Default Configuration Java Code Execution)

Reference Information

CVE: CVE-2011-3389, CVE-2011-3516, CVE-2011-3521, CVE-2011-3544, CVE-2011-3545, CVE-2011-3546, CVE-2011-3547, CVE-2011-3548, CVE-2011-3549, CVE-2011-3550, CVE-2011-3551, CVE-2011-3552, CVE-2011-3553, CVE-2011-3554, CVE-2011-3556, CVE-2011-3557, CVE-2011-3560, CVE-2011-3561

BID: 49778, 50211, 50215, 50216, 50218, 50220, 50223, 50224, 50226, 50229, 50231, 50234, 50236, 50239, 50243, 50246, 50248, 50250

RHSA: 2012:0034