PHP Version 5 Hash Collision Form Parameter Parsing Remote DoS

medium Nessus Plugin ID 57557
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote host is affected by a denial of service vulnerability.

Description

The remote web server uses a version of PHP that is affected by a hash collision denial of service. A flaw exists in the way PHP generates hash tables for user-supplied values. By sending a small number of specially crafted POST requests to a web server that uses PHP, an attacker can take advantage of this flaw to cause a denial of service condition.

Note that this plugin only tests PHP version 5, and it only runs if 'Report paranoia' is set to 'Paranoid' and the 'Perform thorough tests' setting is enabled.

Solution

Upgrade to PHP 5.3.9 or later.

See Also

http://www.nruns.com/_downloads/advisory28122011.pdf

http://www.php.net/ChangeLog-5.php#5.3.9

Plugin Details

Severity: Medium

ID: 57557

File Name: php_5_hash_collision_dos.nbin

Version: 1.70

Type: remote

Family: CGI abuses

Published: 1/16/2012

Updated: 4/20/2021

Dependencies: php_version.nasl, webmirror.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.7

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/11/2012

Vulnerability Publication Date: 12/28/2011

Exploitable With

Core Impact

Metasploit (Hashtable Collisions)

Reference Information

CVE: CVE-2011-4885

BID: 51193

CERT: 903934