SuSE 11.1 Security Update : system-config-printer (SAT Patch Number 5607)

High Nessus Plugin ID 57555


The remote SuSE 11 host is missing one or more security updates.


The following issues have been fixed :

- system-config-printer used an unauthenticated connection when downloading printer drivers from (CVE-2011-4405). This update disables the printer driver download feature.

- system-config-printer did not properly quote shell meta characters in SMB server or workgroup names when passing them to the shell. (CVE-2011-2899)


Apply SAT patch number 5607.

See Also

Plugin Details

Severity: High

ID: 57555

File Name: suse_11_system-config-printer-120104.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2012/01/16

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:system-config-printer, p-cpe:/a:novell:suse_linux:11:system-config-printer-lang, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2012/01/04

Reference Information

CVE: CVE-2011-2899, CVE-2011-4405