SuSE 10 Security Update : wireshark (ZYPP Patch Number 7796)

High Nessus Plugin ID 57263


The remote SuSE 10 host is missing a security-related patch.


This update of wireshark fixes the following vulnerabilities :

- Wireshark IKE dissector vulnerability. (CVE-2011-3266)

- Wireshark Lua script execution vulnerability.

- Wireshark buffer exception handling vulnerability.

- Lucent/Ascend file parser susceptible to infinite loop.

- ANSI MAP dissector susceptible to infinite loop.

- Large/infinite loop in the DICOM dissector.

- A corrupted snoop file could crash Wireshark.

- Malformed compressed capture data could crash Wireshark.

- A corrupted Visual Networks file could crash Wireshark.

- dereferene a NULL pointer if we had a corrupted Diameter dictionary. (CVE-2011-1958)


Apply ZYPP patch number 7796.

See Also

Plugin Details

Severity: High

ID: 57263

File Name: suse_wireshark-7796.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2011/12/13

Modified: 2013/08/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/10/13

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Wireshark console.lua Pre-Loading Script Execution)

Reference Information

CVE: CVE-2011-1957, CVE-2011-1958, CVE-2011-1959, CVE-2011-2174, CVE-2011-2175, CVE-2011-2597, CVE-2011-2698, CVE-2011-3266, CVE-2011-3360, CVE-2011-3483