SuSE 10 Security Update : quagga (ZYPP Patch Number 7406)

Medium Nessus Plugin ID 57249


The remote SuSE 10 host is missing a security-related patch.


This security update of quagga fixes :

- Direct BGP peers can send malformed extended communities which lead to a NULL pointer dereference.

- A malformed AS_PATHLIMIT path attribute will cause a session reset in Quagga. This malformed package is forwarded by other routers and can be used to take 'all' Quagga routers off the Internet with one single announcement. (feature removed). (CVE-2010-1675)

- CVE-2010-2948: CVSS v2 Base Score: 5.4 (AV:A/AC:M/Au:N/C:P/I:P/A:P): Buffer Errors (CWE-119)

- CVE-2010-2949: CVSS v2 Base Score: 1.8 (AV:A/AC:H/Au:N/C:N/I:N/A:P)


Apply ZYPP patch number 7406.

See Also

Plugin Details

Severity: Medium

ID: 57249

File Name: suse_quagga-7406.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2011/12/13

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/03/04

Reference Information

CVE: CVE-2010-1674, CVE-2010-1675, CVE-2010-2948, CVE-2010-2949

CWE: 119