SuSE 11.1 Security Update : xorg-x11-server (SAT Patch Number 5479)

Low Nessus Plugin ID 57138


The remote SuSE 11 host is missing one or more security updates.


This update fixes two security issues with the X server :

- A local attacker could find out if a file exists by exploiting the way that Xorg creates its lock files.

- A non-root local user could set the read permission for all users on any file or directory. (CVE-2011-4029)


Apply SAT patch number 5479.

See Also

Plugin Details

Severity: Low

ID: 57138

File Name: suse_11_xorg-x11-Xvnc-111124.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2011/12/13

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:xorg-x11-Xvnc, p-cpe:/a:novell:suse_linux:11:xorg-x11-server, p-cpe:/a:novell:suse_linux:11:xorg-x11-server-extra, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/11/24

Reference Information

CVE: CVE-2011-4028, CVE-2011-4029