SuSE 11.1 Security Update : openswan (SAT Patch Number 5424)

Medium Nessus Plugin ID 57125


The remote SuSE 11 host is missing one or more security updates.


openswan's crypto helper was prone to an use-after-free flaw which could potentially allow remote attackers to cause a Denial of Service (CVE-2011-4073, bnc#727002). Additionally, the following issues have been fixed :

- AH handshake problems (bnc#713986),

- potential dereference of no longer valid pointers,

- mode handling issues


Apply SAT patch number 5424.

See Also

Plugin Details

Severity: Medium

ID: 57125

File Name: suse_11_openswan-111114.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2011/12/13

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:openswan, p-cpe:/a:novell:suse_linux:11:openswan-doc, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/11/14

Reference Information

CVE: CVE-2011-4073