SuSE 11.1 Security Update : Qt (SAT Patch Number 5131)

High Nessus Plugin ID 57112

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

The following security issues have been fixed :

- Specially crafted font files could cause a single byte heap based buffer overflow. (CVE-2011-3193)

- Specially crafted grey scale images could cause a heap-based buffer overflow. (CVE-2011-3194)

- SSL servers could run into an endless loop (CVE-2010-2621) The update also fixes the following non-security bugs :

- QFileDialog, to show system files (bnc#669604),

- matching of SSL certificates mentioning IP addresses (bnc#637293),

- the font fallback handling (bnc#643848),

- handling of transparent monochromatic pixmaps (bnc#610578),

- a crash of QtWebKit with flash player (bnc#613818)

Solution

Apply SAT patch number 5131.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=610578

https://bugzilla.novell.com/show_bug.cgi?id=613818

https://bugzilla.novell.com/show_bug.cgi?id=619089

https://bugzilla.novell.com/show_bug.cgi?id=637275

https://bugzilla.novell.com/show_bug.cgi?id=637293

https://bugzilla.novell.com/show_bug.cgi?id=643848

https://bugzilla.novell.com/show_bug.cgi?id=668210

https://bugzilla.novell.com/show_bug.cgi?id=669604

https://bugzilla.novell.com/show_bug.cgi?id=714984

http://support.novell.com/security/cve/CVE-2010-2621.html

http://support.novell.com/security/cve/CVE-2011-3193.html

http://support.novell.com/security/cve/CVE-2011-3194.html

Plugin Details

Severity: High

ID: 57112

File Name: suse_11_libQtWebKit-devel-110908.nasl

Version: 1.6

Type: local

Agent: unix

Published: 2011/12/13

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libQtWebKit4, p-cpe:/a:novell:suse_linux:11:libQtWebKit4-32bit, p-cpe:/a:novell:suse_linux:11:libqt4, p-cpe:/a:novell:suse_linux:11:libqt4-32bit, p-cpe:/a:novell:suse_linux:11:libqt4-qt3support, p-cpe:/a:novell:suse_linux:11:libqt4-qt3support-32bit, p-cpe:/a:novell:suse_linux:11:libqt4-sql, p-cpe:/a:novell:suse_linux:11:libqt4-sql-32bit, p-cpe:/a:novell:suse_linux:11:libqt4-sql-mysql, p-cpe:/a:novell:suse_linux:11:libqt4-sql-mysql-32bit, p-cpe:/a:novell:suse_linux:11:libqt4-sql-postgresql, p-cpe:/a:novell:suse_linux:11:libqt4-sql-postgresql-32bit, p-cpe:/a:novell:suse_linux:11:libqt4-sql-sqlite, p-cpe:/a:novell:suse_linux:11:libqt4-sql-sqlite-32bit, p-cpe:/a:novell:suse_linux:11:libqt4-sql-unixODBC, p-cpe:/a:novell:suse_linux:11:libqt4-sql-unixODBC-32bit, p-cpe:/a:novell:suse_linux:11:libqt4-x11, p-cpe:/a:novell:suse_linux:11:libqt4-x11-32bit, p-cpe:/a:novell:suse_linux:11:qt4-qtscript, p-cpe:/a:novell:suse_linux:11:qt4-x11-tools, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/09/08

Reference Information

CVE: CVE-2010-2621, CVE-2011-3193, CVE-2011-3194