FreeBSD : hiawatha -- memory leak in PreventSQLi routine (eef56761-11eb-11e1-bb94-001c140104d4)

High Nessus Plugin ID 56900


The remote FreeBSD host is missing a security-related update.


Hugo Leisink reports via private mail to maintainer :

The memory leak was introduced in version 7.6. It is in the routing that checks for SQL injections. So, if you have set PreventSQLi to 'no', there is no problem.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 56900

File Name: freebsd_pkg_eef5676111eb11e1bb94001c140104d4.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2011/11/22

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:hiawatha, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2011/11/18

Vulnerability Publication Date: 2011/11/18