FreeBSD : kdeutils4 -- Directory traversal vulnerability (7fb9e739-0e6d-11e1-87cd-00235a5f2c9a)

medium Nessus Plugin ID 56806
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Tim Brown from Nth Dimention reports :

I recently discovered that the Ark archiving tool is vulnerable to directory traversal via malformed. When attempts are made to view files within the malformed Zip file in Ark's default view, the wrong file may be displayed due to incorrect construction of the temporary file name. Whilst this does not allow the wrong file to be overwritten, after closing the default view, Ark will then attempt to delete the temporary file which could result in the deletion of the incorrect file.

Solution

Update the affected package.

See Also

https://seclists.org/fulldisclosure/2011/Oct/351

http://www.nessus.org/u?f71de232

Plugin Details

Severity: Medium

ID: 56806

File Name: freebsd_pkg_7fb9e7390e6d11e187cd00235a5f2c9a.nasl

Version: 1.10

Type: local

Published: 11/14/2011

Updated: 1/6/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.3

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:kdeutils, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 11/14/2011

Vulnerability Publication Date: 10/19/2011

Reference Information

CVE: CVE-2011-2725