FreeBSD : OpenTTD -- Denial of service via improperly validated commands (e77befb5-f3f9-11e0-8b5c-b482fe3f522d)

High Nessus Plugin ID 56523


The remote FreeBSD host is missing a security-related update.


The OpenTTD Team reports :

Multiple off-by-one errors in order_cmd.cpp in OpenTTD before 1.1.3 allow remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted CMD_INSERT_ORDER command.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 56523

File Name: freebsd_pkg_e77befb5f3f911e08b5cb482fe3f522d.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2011/10/17

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:openttd, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2011/10/16

Vulnerability Publication Date: 2011/08/25

Reference Information

CVE: CVE-2011-3341