FreeBSD : nwclient -- multiple vulnerabilities (d177d9f9-e317-11d9-8088-00123f0f7307)

High Nessus Plugin ID 56496


The remote FreeBSD host is missing a security-related update.


Insecure file permissions, network access control and DNS usage put systems that use Legato NetWorker at risk.

When the software is running, several files that contain sensitive information are created with insecure permissions. The information exposed include passwords and can therefore be used for privilege elevation.

An empty 'servers' file, which should normally contain hostnames of authorized backup servers, may allow unauthorized backups to be made.
Sensitive information can be extracted from these backups.

When reverse DNS fails for the Legato client IP a weak authorization scheme, containing a flaw that allows unauthorized access, is used.
This may allow unauthorized access.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 56496

File Name: freebsd_pkg_d177d9f9e31711d9808800123f0f7307.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2011/10/14

Modified: 2016/12/08

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:nwclient, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2005/07/08

Vulnerability Publication Date: 2002/01/10

Reference Information

CVE: CVE-2001-0910, CVE-2002-0113, CVE-2002-0114

BID: 3564, 3840, 3842