FreeBSD : ChiTeX/ChiLaTeX unsafe set-user-id root (49ad1bf8-5d7e-11d8-80e3-0020ed76ef5a)

High Nessus Plugin ID 56491


The remote FreeBSD host is missing a security-related update.


Niels Heinen reports that ChiTeX installs set-user-id root executables that invoked system(3) without setting up the environment, trivially allowing local root compromise.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 56491

File Name: freebsd_pkg_49ad1bf85d7e11d880e30020ed76ef5a.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2011/10/14

Modified: 2015/08/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:zh-chitex, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2004/02/12

Vulnerability Publication Date: 2003/04/25