Debian DSA-2306-1 : ffmpeg - several vulnerabilities

High Nessus Plugin ID 56144

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in FFmpeg, a multimedia player, server and encoder. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2010-3908 FFmpeg before 0.5.4, allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a malformed WMV file.

- CVE-2010-4704 libavcodec/vorbis_dec.c in the Vorbis decoder in FFmpeg allows remote attackers to cause a denial of service (application crash) via a crafted Ogg file, related to the vorbis_floor0_decode function.

- CVE-2011-0480 Multiple buffer overflows in vorbis_dec.c in the Vorbis decoder in FFmpeg allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact via a crafted WebM file, related to buffers for the channel floor and the channel residue.

- CVE-2011-0722 FFmpeg allows remote attackers to cause a denial of service (heap memory corruption and application crash) or possibly execute arbitrary code via a malformed RealMedia file.

Solution

Upgrade the ffmpeg packages.

For the stable distribution (squeeze), this problem has been fixed in version 4:0.5.4-1.

Security support for ffmpeg has been discontinued for the oldstable distribution (lenny). The current version in oldstable is not supported by upstream anymore and is affected by several security issues. Backporting fixes for these and any future issues has become unfeasible and therefore we need to drop our security support for the version in oldstable.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=611495

https://security-tracker.debian.org/tracker/CVE-2010-3908

https://security-tracker.debian.org/tracker/CVE-2010-4704

https://security-tracker.debian.org/tracker/CVE-2011-0480

https://security-tracker.debian.org/tracker/CVE-2011-0722

https://packages.debian.org/source/squeeze/ffmpeg

https://www.debian.org/security/2011/dsa-2306

Plugin Details

Severity: High

ID: 56144

File Name: debian_DSA-2306.nasl

Version: 1.11

Type: local

Agent: unix

Published: 2011/09/12

Updated: 2020/03/12

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ffmpeg, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/09/11

Reference Information

CVE: CVE-2010-3908, CVE-2010-4704, CVE-2011-0480, CVE-2011-0722, CVE-2011-0723

BID: 45788, 46294, 47147, 47149, 47151, 47154

DSA: 2306