FreeBSD : hlstats -- multiple XSS vulnerabilities (09639ccc-3abb-11db-81e1-000e0c2e438a)

High Nessus Plugin ID 56077


The remote FreeBSD host is missing a security-related update.


Kefka reports multiple cross site scripting vulnerabilities within hlstats. The vulnerabilities are caused due to improper checking of variables, allowing an attacker to perform cross site scripting.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 56077

File Name: freebsd_pkg_09639ccc3abb11db81e1000e0c2e438a.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2011/09/06

Modified: 2014/08/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:W/RC:ND

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:hlstats, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/09/02

Vulnerability Publication Date: 2006/08/29

Reference Information

CVE: CVE-2006-4454, CVE-2006-6780, CVE-2006-6781, CVE-2007-2812

BID: 19745