SuSE 11.1 Security Update : hplip (SAT Patch Number 4989)

High Nessus Plugin ID 55981


The remote SuSE 11 host is missing one or more security updates.


This update of hplip fixes :

- This patch originally affected foomatic-rip in CUPS but was found to be in foomatic-rip-hplip too.
(CVE-2004-0801: CVSS v2 Base Score: 7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P))

- The foomatic print filters of the hplip package contained a remote code execution vulnerability. Remote users, if allowed to access a print server such as CUPS, could execute arbitrary commands as lp system user.
(CVE-2011-2697: CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P))


Apply SAT patch number 4989.

See Also

Plugin Details

Severity: High

ID: 55981

File Name: suse_11_hplip-110812.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2011/08/26

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:hplip, p-cpe:/a:novell:suse_linux:11:hplip-hpijs, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/08/12

Reference Information

CVE: CVE-2004-0801, CVE-2011-2697