FreeBSD : rubygem-rails -- multiple vulnerabilities (be77eff6-ca91-11e0-aea3-00215c6a37bb)

High Nessus Plugin ID 55915


The remote FreeBSD host is missing a security-related update.


SecurityFocus reports :

Ruby on Rails is prone to multiple vulnerabilities including SQL-injection, information-disclosure, HTTP-header-injection, security-bypass and cross-site scripting issues.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 55915

File Name: freebsd_pkg_be77eff6ca9111e0aea300215c6a37bb.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2011/08/20

Modified: 2015/01/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem-rails, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/08/19

Vulnerability Publication Date: 2011/08/16

Reference Information

BID: 49179