SuSE9 Security Update : foomatic-filters (YOU Patch Number 12818)

Medium Nessus Plugin ID 55826


The remote SuSE 9 host is missing a security-related patch.


The foomatic print filters of the hplip package contained a remote code execution vulnerability. Remote users, if allowed to access a print server such as CUPS, could execute arbitrary commands as lp system user.

- CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P):
Input Validation (CWE-20). (CVE-2011-2697)


Apply YOU patch number 12818.

See Also

Plugin Details

Severity: Medium

ID: 55826

File Name: suse9_12818.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2011/08/12

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2011/08/08

Reference Information

CVE: CVE-2011-2697, CVE-2011-2964

CWE: 20